Deep SSL/TLS Vulnerability Test

This report provides a deep analysis of the SSL/TLS configuration of spideraf.com. It checks for protocol support, cipher strength, and known vulnerabilities.

Scan Results

Testing all IP addresses (port 443): 3.113.204.138 35.73.26.0
-----------------------------------------------------
 Start 2026-09-21 15:30:54        -->> 3.113.204.138:443 (spideraf.com) <<--

 Further IP addresses:   35.73.26.0 
 rDNS (3.113.204.138):   ec2-3-113-204-138.ap-northeast-1.compute.amazonaws.com.
 Service detected:       HTTP

 Testing for server implementation bugs 

 No bugs found.

 Testing HTTP header response @ "/" 

 HTTP Status Code             200 OK
 HTTP clock skew              +312319 sec from localtime
 HTTP Age (RFC 7234)          312320
 IPv4 address in header       set-cookie: _cfuvid=..eiwN3go0GztiMZiP1uiO0jeDBw3JzUSdQ9V2_qe20-1790004708.3983698-1.0.1.1-UaEbYCcwGj9acSxjFTbqkDlV04FSIiQ2i2AICNaF7KQ; HttpOnly; SameSite=None; Secure; Path=/; Domain=global.spideraf.com
                              (check if it's your IP address or e.g. a cluster IP)
 Strict Transport Security    730 days=63072000 s, includeSubDomains, preload
 Public Key Pinning           --
 Server banner                (no "Server" line in header, interesting!)
 Application banner           --
 Cookie(s)                    4 issued: 3/4 secure, 2/4 HttpOnly
 Security headers             misconfiguration: X-Frame-Options 2x -- checking first one only
                              X-Frame-Options: SAMEORIGIN
                              X-Content-Type-Options: nosniff
                              Content-Security-Policy: frame-ancestors 'self'
                              Content-Security-Policy-Report-Only: default-src
                                'self'; script-src-elem 'self' 'unsafe-inline'
                                https://cdnjs.cloudflare.com
                                https://tag.flvcdn.net
                                https://saf-sc-protect.com
                                https://hubspotonwebflow.com
                                https://www.rentracks.jp
                                https://b98.yahoo.co.jp https://ichisan.jp
                                https://sc.lfeeder.com https://trc.taboola.com
                                https://b99.yahoo.co.jp
                                https://static.ads-twitter.com
                                https://bat.bing.com https://s.yimg.jp
                                https://platform.twitter.com
                                https://d.line-scdn.net https://cdn.taboola.com
                                https://m.vpadn.com
                                https://funnel-assets.startappservice.com
                                https://tools.refokus.com
                                https://*.intercomcdn.com https://*.intercom.io
                                https://*.jsdelivr.net https://js.hsforms.net
                                https://*.visualwebsiteoptimizer.com
                                https://snap.licdn.com
                                https://connect.facebook.net
                                https://tracking.g2crowd.com
                                https://*.spideraf.com
                                https://*.hscollectedforms.net
                                https://*.hs-analytics.net
                                https://*.hsadspixel.net
                                https://*.hs-banner.com https://*.hubspot.com
                                https://*.clarity.ms
                                https://googleads.g.doubleclick.net
                                https://*.hs-scripts.com https://*.webflow.com
                                https://*.jetboost.io
                                https://*.website-files.com
                                https://www.googletagmanager.com
                                https://*.googleapis.com https://*.jquery.com
                                https://*.cloudfront.net
                                https://cdn-cookieyes.com https://sp-trk.com;
                                script-src 'self' 'unsafe-inline' 'unsafe-eval'
                                https://*.webflow.com
                                https://www.googletagmanager.com
                                https://*.googleapis.com https://*.jquery.com
                                https://*.cloudfront.net
                                https://cdn-cookieyes.com https://*.intercom.io
                                https://sp-trk.com https://*.jetboost.io
                                https://*.visualwebsiteoptimizer.com
                                https://*.cloudflare.com; style-src 'self'
                                'unsafe-inline' https://*; font-src 'self'
                                data: https://*; img-src 'self' data: blob:
                                https://*; connect-src 'self' https://*;
                                frame-src 'self' https://*; worker-src 'self'
                                blob:; object-src 'none'; report-uri
                                https://saf-sitescan.com/api/csp-report/4rjsitdq;
                              Permissions-Policy: gyroscope=(), microphone=(),
                                fullscreen=(self)
                              X-XSS-Protection: 1; mode=block
                              Permissions-Policy: gyroscope=(), microphone=(),
                                fullscreen=(self)
                              Referrer-Policy: strict-origin-when-cross-origin
 Reverse Proxy banner         --


 Testing vulnerabilities 

 Secure Renegotiation (RFC 5746)           supported (OK)
 Secure Client-Initiated Renegotiation     not vulnerable (OK)
 CRIME, TLS (CVE-2012-4929)                not vulnerable (OK)
 BREACH (CVE-2013-3587)                    potentially NOT ok, "gzip br" HTTP compression detected. - only supplied "/" tested
                                           Can be ignored for static pages or if no secrets in the page
 POODLE, SSL (CVE-2014-3566)               not vulnerable (OK)
 TLS_FALLBACK_SCSV (RFC 7507)              No fallback possible (OK), no protocol below TLS 1.2 offered
 SWEET32 (CVE-2016-2183, CVE-2016-6329)    not vulnerable (OK)
 FREAK (CVE-2015-0204)                     not vulnerable (OK)
 DROWN (CVE-2016-0800, CVE-2016-0703)      not vulnerable on this host and port (OK)
                                           make sure you don't use this certificate elsewhere with SSLv2 enabled services, see
                                           https://search.censys.io/search?resource=hosts&virtual_hosts=INCLUDE&q=4898BAE0C0DA8DADDAC9EFCF9118FB166438685CDA0C954AF4DD8190A7FAD951
 LOGJAM (CVE-2015-4000), experimental      not vulnerable (OK): no DH EXPORT ciphers, no DH key detected with <= TLS 1.2
 BEAST (CVE-2011-3389)                     not vulnerable (OK), no SSL3 or TLS1
 LUCKY13 (CVE-2013-0169), experimental     potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs.
 Winshock (CVE-2014-6321), experimental    not vulnerable (OK)
 RC4 (CVE-2013-2566, CVE-2015-2808)        no RC4 ciphers detected (OK)


 Done 2026-09-21 15:32:37 [ 113s] -->> 3.113.204.138:443 (spideraf.com) <<--

-----------------------------------------------------
 Start 2026-09-21 15:32:37        -->> 35.73.26.0:443 (spideraf.com) <<--

 Further IP addresses:   3.113.204.138 
 rDNS (35.73.26.0):      ec2-35-73-26-0.ap-northeast-1.compute.amazonaws.com.
 Service detected:       HTTP

 Testing for server implementation bugs 

 No bugs found.

 Testing HTTP header response @ "/" 

 HTTP Status Code             200 OK
 HTTP clock skew              +312434 sec from localtime
 HTTP Age (RFC 7234)          312435
 IPv4 address in header       set-cookie: _cfuvid=T5oegHEumEFYhU6MGLe9KHWKAWrE3f7Q.Fztv8yN.no-1790004823.722133-1.0.1.1-l9Q4SDGTpkxwk1By4Xkymo4PyFlfq7vaQ6.u9MEGq5I; HttpOnly; SameSite=None; Secure; Path=/; Domain=global.spideraf.com
                              (check if it's your IP address or e.g. a cluster IP)
 Strict Transport Security    730 days=63072000 s, includeSubDomains, preload
 Public Key Pinning           --
 Server banner                (no "Server" line in header, interesting!)
 Application banner           --
 Cookie(s)                    4 issued: 3/4 secure, 2/4 HttpOnly
 Security headers             misconfiguration: X-Frame-Options 2x -- checking first one only
                              X-Frame-Options: SAMEORIGIN
                              X-Content-Type-Options: nosniff
                              Content-Security-Policy: frame-ancestors 'self'
                              Content-Security-Policy-Report-Only: default-src
                                'self'; script-src-elem 'self' 'unsafe-inline'
                                https://cdnjs.cloudflare.com
                                https://tag.flvcdn.net
                                https://saf-sc-protect.com
                                https://hubspotonwebflow.com
                                https://www.rentracks.jp
                                https://b98.yahoo.co.jp https://ichisan.jp
                                https://sc.lfeeder.com https://trc.taboola.com
                                https://b99.yahoo.co.jp
                                https://static.ads-twitter.com
                                https://bat.bing.com https://s.yimg.jp
                                https://platform.twitter.com
                                https://d.line-scdn.net https://cdn.taboola.com
                                https://m.vpadn.com
                                https://funnel-assets.startappservice.com
                                https://tools.refokus.com
                                https://*.intercomcdn.com https://*.intercom.io
                                https://*.jsdelivr.net https://js.hsforms.net
                                https://*.visualwebsiteoptimizer.com
                                https://snap.licdn.com
                                https://connect.facebook.net
                                https://tracking.g2crowd.com
                                https://*.spideraf.com
                                https://*.hscollectedforms.net
                                https://*.hs-analytics.net
                                https://*.hsadspixel.net
                                https://*.hs-banner.com https://*.hubspot.com
                                https://*.clarity.ms
                                https://googleads.g.doubleclick.net
                                https://*.hs-scripts.com https://*.webflow.com
                                https://*.jetboost.io
                                https://*.website-files.com
                                https://www.googletagmanager.com
                                https://*.googleapis.com https://*.jquery.com
                                https://*.cloudfront.net
                                https://cdn-cookieyes.com https://sp-trk.com;
                                script-src 'self' 'unsafe-inline' 'unsafe-eval'
                                https://*.webflow.com
                                https://www.googletagmanager.com
                                https://*.googleapis.com https://*.jquery.com
                                https://*.cloudfront.net
                                https://cdn-cookieyes.com https://*.intercom.io
                                https://sp-trk.com https://*.jetboost.io
                                https://*.visualwebsiteoptimizer.com
                                https://*.cloudflare.com; style-src 'self'
                                'unsafe-inline' https://*; font-src 'self'
                                data: https://*; img-src 'self' data: blob:
                                https://*; connect-src 'self' https://*;
                                frame-src 'self' https://*; worker-src 'self'
                                blob:; object-src 'none'; report-uri
                                https://saf-sitescan.com/api/csp-report/4rjsitdq;
                              Permissions-Policy: gyroscope=(), microphone=(),
                                fullscreen=(self)
                              X-XSS-Protection: 1; mode=block
                              Permissions-Policy: gyroscope=(), microphone=(),
                                fullscreen=(self)
                              Referrer-Policy: strict-origin-when-cross-origin
 Reverse Proxy banner         --


 Testing vulnerabilities 

 Secure Renegotiation (RFC 5746)           supported (OK)
 Secure Client-Initiated Renegotiation     not vulnerable (OK)
 CRIME, TLS (CVE-2012-4929)                not vulnerable (OK)
 BREACH (CVE-2013-3587)                    potentially NOT ok, "gzip br" HTTP compression detected. - only supplied "/" tested
                                           Can be ignored for static pages or if no secrets in the page
 POODLE, SSL (CVE-2014-3566)               not vulnerable (OK)
 TLS_FALLBACK_SCSV (RFC 7507)              No fallback possible (OK), no protocol below TLS 1.2 offered
 SWEET32 (CVE-2016-2183, CVE-2016-6329)    not vulnerable (OK)
 FREAK (CVE-2015-0204)                     not vulnerable (OK)
 DROWN (CVE-2016-0800, CVE-2016-0703)      not vulnerable on this host and port (OK)
                                           make sure you don't use this certificate elsewhere with SSLv2 enabled services, see
                                           https://search.censys.io/search?resource=hosts&virtual_hosts=INCLUDE&q=4898BAE0C0DA8DADDAC9EFCF9118FB166438685CDA0C954AF4DD8190A7FAD951
 LOGJAM (CVE-2015-4000), experimental      not vulnerable (OK): no DH EXPORT ciphers, no DH key detected with <= TLS 1.2
 BEAST (CVE-2011-3389)                     not vulnerable (OK), no SSL3 or TLS1
 LUCKY13 (CVE-2013-0169), experimental     potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs.
 Winshock (CVE-2014-6321), experimental    not vulnerable (OK)
 RC4 (CVE-2013-2566, CVE-2015-2808)        no RC4 ciphers detected (OK)


 Done 2026-09-21 15:34:34 [ 230s] -->> 35.73.26.0:443 (spideraf.com) <<--

-----------------------------------------------------
Done testing now all IP addresses (on port 443): 3.113.204.138 35.73.26.0

About this Scan

This scan uses testssl.sh to check for:

  • Protocols: SSLv2, SSLv3, TLS 1.0, TLS 1.1, TLS 1.2, TLS 1.3
  • Vulnerabilities: Heartbleed, POODLE, FREAK, Logjam, DROWN, etc.
  • Cipher Suites: Weak ciphers, perfect forward secrecy (PFS) support.

Run Another Scan Recent Scans