Deep SSL/TLS Vulnerability Test
This report provides a deep analysis of the SSL/TLS configuration of pypi-camo.freetls.fastly.net. It checks for protocol support, cipher strength, and known vulnerabilities.
Scan Results
Testing all IP addresses (port 443): 151.101.2.79 151.101.130.79 151.101.66.79 151.101.194.79 ----------------------------------------------------- Start 2026-10-05 06:41:57 -->> 151.101.2.79:443 (pypi-camo.freetls.fastly.net) <<-- Further IP addresses: 151.101.194.79 151.101.130.79 151.101.66.79 2a04:4e42:600::591 2a04:4e42:200::591 2a04:4e42:400::591 2a04:4e42::591 rDNS (151.101.2.79): -- Service detected: HTTP Testing for server implementation bugs No bugs found. Testing HTTP header response @ "/" HTTP Status Code 404 Not Found (Hint: supply a path which doesn't give a "404 Not Found") HTTP clock skew +1 sec from localtime HTTP Age (RFC 7234) 1 Strict Transport Security 300 s = 0 days is too short ( >= 15552000 seconds recommended), just this domain Public Key Pinning -- Server banner https://github.com/pypi/camo Application banner -- Cookie(s) (none issued at "/") -- HTTP status 404 signals you maybe missed the web application Security headers X-Content-Type-Options: nosniff Content-Security-Policy: default-src 'none'; img-src data:; style-src 'unsafe-inline' X-XSS-Protection: 1; mode=block Access-Control-Allow-Origin: https://pypi.org X-Served-By: cache-chi-kigq8000079-CHI Reverse Proxy banner Via: 1.1 varnish X-Cache: HIT X-Cache-Hits: 1 Testing vulnerabilities Secure Renegotiation (RFC 5746) supported (OK) Secure Client-Initiated Renegotiation not vulnerable (OK) CRIME, TLS (CVE-2012-4929) not vulnerable (OK) BREACH (CVE-2013-3587) no gzip/deflate/compress/br HTTP compression (OK) - only supplied "/" tested POODLE, SSL (CVE-2014-3566) not vulnerable (OK) TLS_FALLBACK_SCSV (RFC 7507) No fallback possible (OK), no protocol below TLS 1.2 offered SWEET32 (CVE-2016-2183, CVE-2016-6329) not vulnerable (OK) FREAK (CVE-2015-0204) not vulnerable (OK) DROWN (CVE-2016-0800, CVE-2016-0703) not vulnerable on this host and port (OK) make sure you don't use this certificate elsewhere with SSLv2 enabled services, see https://search.censys.io/search?resource=hosts&virtual_hosts=INCLUDE&q=7910C7C866F38FFC5FE0904282D75EB8637EB6198B12E9EB68416830A7954BFF LOGJAM (CVE-2015-4000), experimental not vulnerable (OK): no DH EXPORT ciphers, no DH key detected with <= TLS 1.2 BEAST (CVE-2011-3389) not vulnerable (OK), no SSL3 or TLS1 LUCKY13 (CVE-2013-0169), experimental potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs. Winshock (CVE-2014-6321), experimental not vulnerable (OK) - ARIA, CHACHA or CCM ciphers found RC4 (CVE-2013-2566, CVE-2015-2808) no RC4 ciphers detected (OK) Done 2026-10-05 06:42:34 [ 45s] -->> 151.101.2.79:443 (pypi-camo.freetls.fastly.net) <<-- ----------------------------------------------------- Start 2026-10-05 06:42:34 -->> 151.101.130.79:443 (pypi-camo.freetls.fastly.net) <<-- Further IP addresses: 151.101.194.79 151.101.2.79 151.101.66.79 2a04:4e42:600::591 2a04:4e42:200::591 2a04:4e42:400::591 2a04:4e42::591 rDNS (151.101.130.79): -- Service detected: HTTP Testing for server implementation bugs No bugs found. Testing HTTP header response @ "/" HTTP Status Code 404 Not Found (Hint: supply a path which doesn't give a "404 Not Found") HTTP clock skew +1 sec from localtime HTTP Age (RFC 7234) 1 Strict Transport Security 300 s = 0 days is too short ( >= 15552000 seconds recommended), just this domain Public Key Pinning -- Server banner https://github.com/pypi/camo Application banner -- Cookie(s) (none issued at "/") -- HTTP status 404 signals you maybe missed the web application Security headers X-Content-Type-Options: nosniff Content-Security-Policy: default-src 'none'; img-src data:; style-src 'unsafe-inline' X-XSS-Protection: 1; mode=block Access-Control-Allow-Origin: https://pypi.org X-Served-By: cache-chi-klot8100129-CHI Reverse Proxy banner Via: 1.1 varnish X-Cache: HIT X-Cache-Hits: 1 Testing vulnerabilities Secure Renegotiation (RFC 5746) supported (OK) Secure Client-Initiated Renegotiation not vulnerable (OK) CRIME, TLS (CVE-2012-4929) not vulnerable (OK) BREACH (CVE-2013-3587) no gzip/deflate/compress/br HTTP compression (OK) - only supplied "/" tested POODLE, SSL (CVE-2014-3566) not vulnerable (OK) TLS_FALLBACK_SCSV (RFC 7507) No fallback possible (OK), no protocol below TLS 1.2 offered SWEET32 (CVE-2016-2183, CVE-2016-6329) not vulnerable (OK) FREAK (CVE-2015-0204) not vulnerable (OK) DROWN (CVE-2016-0800, CVE-2016-0703) not vulnerable on this host and port (OK) make sure you don't use this certificate elsewhere with SSLv2 enabled services, see https://search.censys.io/search?resource=hosts&virtual_hosts=INCLUDE&q=7910C7C866F38FFC5FE0904282D75EB8637EB6198B12E9EB68416830A7954BFF LOGJAM (CVE-2015-4000), experimental not vulnerable (OK): no DH EXPORT ciphers, no DH key detected with <= TLS 1.2 BEAST (CVE-2011-3389) not vulnerable (OK), no SSL3 or TLS1 LUCKY13 (CVE-2013-0169), experimental potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs. Winshock (CVE-2014-6321), experimental not vulnerable (OK) - ARIA, CHACHA or CCM ciphers found RC4 (CVE-2013-2566, CVE-2015-2808) no RC4 ciphers detected (OK) Done 2026-10-05 06:43:18 [ 89s] -->> 151.101.130.79:443 (pypi-camo.freetls.fastly.net) <<-- ----------------------------------------------------- Start 2026-10-05 06:43:18 -->> 151.101.66.79:443 (pypi-camo.freetls.fastly.net) <<-- Further IP addresses: 151.101.194.79 151.101.2.79 151.101.130.79 2a04:4e42:600::591 2a04:4e42:200::591 2a04:4e42:400::591 2a04:4e42::591 rDNS (151.101.66.79): -- Service detected: HTTP Testing for server implementation bugs No bugs found. Testing HTTP header response @ "/" HTTP Status Code 404 Not Found (Hint: supply a path which doesn't give a "404 Not Found") HTTP clock skew +1 sec from localtime HTTP Age (RFC 7234) 1 Strict Transport Security 300 s = 0 days is too short ( >= 15552000 seconds recommended), just this domain Public Key Pinning -- Server banner https://github.com/pypi/camo Application banner -- Cookie(s) (none issued at "/") -- HTTP status 404 signals you maybe missed the web application Security headers X-Content-Type-Options: nosniff Content-Security-Policy: default-src 'none'; img-src data:; style-src 'unsafe-inline' X-XSS-Protection: 1; mode=block Access-Control-Allow-Origin: https://pypi.org X-Served-By: cache-chi-klot8100146-CHI Reverse Proxy banner Via: 1.1 varnish X-Cache: HIT X-Cache-Hits: 1 Testing vulnerabilities Secure Renegotiation (RFC 5746) supported (OK) Secure Client-Initiated Renegotiation not vulnerable (OK) CRIME, TLS (CVE-2012-4929) not vulnerable (OK) BREACH (CVE-2013-3587) no gzip/deflate/compress/br HTTP compression (OK) - only supplied "/" tested POODLE, SSL (CVE-2014-3566) not vulnerable (OK) TLS_FALLBACK_SCSV (RFC 7507) No fallback possible (OK), no protocol below TLS 1.2 offered SWEET32 (CVE-2016-2183, CVE-2016-6329) not vulnerable (OK) FREAK (CVE-2015-0204) not vulnerable (OK) DROWN (CVE-2016-0800, CVE-2016-0703) not vulnerable on this host and port (OK) make sure you don't use this certificate elsewhere with SSLv2 enabled services, see https://search.censys.io/search?resource=hosts&virtual_hosts=INCLUDE&q=7910C7C866F38FFC5FE0904282D75EB8637EB6198B12E9EB68416830A7954BFF LOGJAM (CVE-2015-4000), experimental not vulnerable (OK): no DH EXPORT ciphers, no DH key detected with <= TLS 1.2 BEAST (CVE-2011-3389) not vulnerable (OK), no SSL3 or TLS1 LUCKY13 (CVE-2013-0169), experimental potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs. Winshock (CVE-2014-6321), experimental not vulnerable (OK) - ARIA, CHACHA or CCM ciphers found RC4 (CVE-2013-2566, CVE-2015-2808) no RC4 ciphers detected (OK) Done 2026-10-05 06:44:01 [ 132s] -->> 151.101.66.79:443 (pypi-camo.freetls.fastly.net) <<-- ----------------------------------------------------- Start 2026-10-05 06:44:01 -->> 151.101.194.79:443 (pypi-camo.freetls.fastly.net) <<-- Further IP addresses: 151.101.2.79 151.101.130.79 151.101.66.79 2a04:4e42:600::591 2a04:4e42:200::591 2a04:4e42:400::591 2a04:4e42::591 rDNS (151.101.194.79): -- Service detected: HTTP Testing for server implementation bugs No bugs found. Testing HTTP header response @ "/" HTTP Status Code 404 Not Found (Hint: supply a path which doesn't give a "404 Not Found") HTTP clock skew +1 sec from localtime HTTP Age (RFC 7234) 1 Strict Transport Security 300 s = 0 days is too short ( >= 15552000 seconds recommended), just this domain Public Key Pinning -- Server banner https://github.com/pypi/camo Application banner -- Cookie(s) (none issued at "/") -- HTTP status 404 signals you maybe missed the web application Security headers X-Content-Type-Options: nosniff Content-Security-Policy: default-src 'none'; img-src data:; style-src 'unsafe-inline' X-XSS-Protection: 1; mode=block Access-Control-Allow-Origin: https://pypi.org X-Served-By: cache-chi-klot8100092-CHI Reverse Proxy banner Via: 1.1 varnish X-Cache: HIT X-Cache-Hits: 1 Testing vulnerabilities Secure Renegotiation (RFC 5746) supported (OK) Secure Client-Initiated Renegotiation not vulnerable (OK) CRIME, TLS (CVE-2012-4929) not vulnerable (OK) BREACH (CVE-2013-3587) no gzip/deflate/compress/br HTTP compression (OK) - only supplied "/" tested POODLE, SSL (CVE-2014-3566) not vulnerable (OK) TLS_FALLBACK_SCSV (RFC 7507) No fallback possible (OK), no protocol below TLS 1.2 offered SWEET32 (CVE-2016-2183, CVE-2016-6329) not vulnerable (OK) FREAK (CVE-2015-0204) not vulnerable (OK) DROWN (CVE-2016-0800, CVE-2016-0703) not vulnerable on this host and port (OK) make sure you don't use this certificate elsewhere with SSLv2 enabled services, see https://search.censys.io/search?resource=hosts&virtual_hosts=INCLUDE&q=7910C7C866F38FFC5FE0904282D75EB8637EB6198B12E9EB68416830A7954BFF LOGJAM (CVE-2015-4000), experimental not vulnerable (OK): no DH EXPORT ciphers, no DH key detected with <= TLS 1.2 BEAST (CVE-2011-3389) not vulnerable (OK), no SSL3 or TLS1 LUCKY13 (CVE-2013-0169), experimental potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs. Winshock (CVE-2014-6321), experimental not vulnerable (OK) - ARIA, CHACHA or CCM ciphers found RC4 (CVE-2013-2566, CVE-2015-2808) no RC4 ciphers detected (OK) Done 2026-10-05 06:44:46 [ 177s] -->> 151.101.194.79:443 (pypi-camo.freetls.fastly.net) <<-- ----------------------------------------------------- Done testing now all IP addresses (on port 443): 151.101.2.79 151.101.130.79 151.101.66.79 151.101.194.79
About this Scan
This scan uses testssl.sh to check for:
- Protocols: SSLv2, SSLv3, TLS 1.0, TLS 1.1, TLS 1.2, TLS 1.3
- Vulnerabilities: Heartbleed, POODLE, FREAK, Logjam, DROWN, etc.
- Cipher Suites: Weak ciphers, perfect forward secrecy (PFS) support.