Deep SSL/TLS Vulnerability Test
This report provides a deep analysis of the SSL/TLS configuration of privacy.reverso.net. It checks for protocol support, cipher strength, and known vulnerabilities.
Scan Results
Testing all IP addresses (port 443): 99.86.77.121 99.86.77.101 99.86.77.88 99.86.77.72 ----------------------------------------------------- Start 2026-09-20 14:57:32 -->> 99.86.77.121:443 (privacy.reverso.net) <<-- Further IP addresses: 99.86.77.72 99.86.77.101 99.86.77.88 rDNS (99.86.77.121): server-99-86-77-121.ord56.r.cloudfront.net. Service detected: HTTP Testing for server implementation bugs No bugs found. Testing HTTP header response @ "/" HTTP Status Code 200 OK HTTP clock skew +1 sec from localtime HTTP Age (RFC 7234) 3359 Strict Transport Security not offered Public Key Pinning -- Server banner AmazonS3 Application banner -- Cookie(s) (none issued at "/") Security headers Cache-Control: public, max-age=3600 Reverse Proxy banner Via: 1.1 abcdd9ead509c6f31d96ed9f797fd698.cloudfront.net (CloudFront), 1.1 95b160439e9b90236fabced21dbc2a88.cloudfront.net (CloudFront) X-Cache: Miss from cloudfront Testing vulnerabilities Secure Renegotiation (RFC 5746) supported (OK) Secure Client-Initiated Renegotiation not vulnerable (OK) CRIME, TLS (CVE-2012-4929) not vulnerable (OK) BREACH (CVE-2013-3587) potentially NOT ok, "gzip br" HTTP compression detected. - only supplied "/" tested Can be ignored for static pages or if no secrets in the page POODLE, SSL (CVE-2014-3566) not vulnerable (OK) TLS_FALLBACK_SCSV (RFC 7507) No fallback possible (OK), no protocol below TLS 1.2 offered SWEET32 (CVE-2016-2183, CVE-2016-6329) not vulnerable (OK) FREAK (CVE-2015-0204) not vulnerable (OK) DROWN (CVE-2016-0800, CVE-2016-0703) not vulnerable on this host and port (OK) make sure you don't use this certificate elsewhere with SSLv2 enabled services, see https://search.censys.io/search?resource=hosts&virtual_hosts=INCLUDE&q=96349848BC554EA65EC53A8252AD1D3F6BEBCABBD5A91BA6EE0C7F81A626AC84 LOGJAM (CVE-2015-4000), experimental not vulnerable (OK): no DH EXPORT ciphers, no DH key detected with <= TLS 1.2 BEAST (CVE-2011-3389) not vulnerable (OK), no SSL3 or TLS1 LUCKY13 (CVE-2013-0169), experimental potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs. Winshock (CVE-2014-6321), experimental not vulnerable (OK) RC4 (CVE-2013-2566, CVE-2015-2808) no RC4 ciphers detected (OK) Done 2026-09-20 14:58:45 [ 80s] -->> 99.86.77.121:443 (privacy.reverso.net) <<-- ----------------------------------------------------- Start 2026-09-20 14:58:45 -->> 99.86.77.101:443 (privacy.reverso.net) <<-- Further IP addresses: 99.86.77.72 99.86.77.121 99.86.77.88 rDNS (99.86.77.101): server-99-86-77-101.ord56.r.cloudfront.net. Service detected: HTTP Testing for server implementation bugs No bugs found. Testing HTTP header response @ "/" HTTP Status Code 200 OK HTTP clock skew +1 sec from localtime HTTP Age (RFC 7234) 3440 Strict Transport Security not offered Public Key Pinning -- Server banner AmazonS3 Application banner -- Cookie(s) (none issued at "/") Security headers Cache-Control: public, max-age=3600 Reverse Proxy banner Via: 1.1 abcdd9ead509c6f31d96ed9f797fd698.cloudfront.net (CloudFront), 1.1 a9fe006b1d77d3f7908af9270fba7714.cloudfront.net (CloudFront) X-Cache: Miss from cloudfront Testing vulnerabilities Secure Renegotiation (RFC 5746) supported (OK) Secure Client-Initiated Renegotiation not vulnerable (OK) CRIME, TLS (CVE-2012-4929) not vulnerable (OK) BREACH (CVE-2013-3587) potentially NOT ok, "gzip br" HTTP compression detected. - only supplied "/" tested Can be ignored for static pages or if no secrets in the page POODLE, SSL (CVE-2014-3566) not vulnerable (OK) TLS_FALLBACK_SCSV (RFC 7507) No fallback possible (OK), no protocol below TLS 1.2 offered SWEET32 (CVE-2016-2183, CVE-2016-6329) not vulnerable (OK) FREAK (CVE-2015-0204) not vulnerable (OK) DROWN (CVE-2016-0800, CVE-2016-0703) not vulnerable on this host and port (OK) make sure you don't use this certificate elsewhere with SSLv2 enabled services, see https://search.censys.io/search?resource=hosts&virtual_hosts=INCLUDE&q=96349848BC554EA65EC53A8252AD1D3F6BEBCABBD5A91BA6EE0C7F81A626AC84 LOGJAM (CVE-2015-4000), experimental not vulnerable (OK): no DH EXPORT ciphers, no DH key detected with <= TLS 1.2 BEAST (CVE-2011-3389) not vulnerable (OK), no SSL3 or TLS1 LUCKY13 (CVE-2013-0169), experimental potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs. Winshock (CVE-2014-6321), experimental not vulnerable (OK) RC4 (CVE-2013-2566, CVE-2015-2808) no RC4 ciphers detected (OK) Done 2026-09-20 15:00:05 [ 160s] -->> 99.86.77.101:443 (privacy.reverso.net) <<-- ----------------------------------------------------- Start 2026-09-20 15:00:05 -->> 99.86.77.88:443 (privacy.reverso.net) <<-- Further IP addresses: 99.86.77.72 99.86.77.121 99.86.77.101 rDNS (99.86.77.88): server-99-86-77-88.ord56.r.cloudfront.net. Service detected: HTTP Testing for server implementation bugs No bugs found. Testing HTTP header response @ "/" HTTP Status Code 200 OK HTTP clock skew +1 sec from localtime HTTP Age (RFC 7234) 3511 Strict Transport Security not offered Public Key Pinning -- Server banner AmazonS3 Application banner -- Cookie(s) (none issued at "/") Security headers Cache-Control: public, max-age=3600 Reverse Proxy banner Via: 1.1 788c5a18883f334d0b09e6cda9d22c86.cloudfront.net (CloudFront), 1.1 e881b2099b9763a06f320c7f8d87d20e.cloudfront.net (CloudFront) X-Cache: Miss from cloudfront Testing vulnerabilities Secure Renegotiation (RFC 5746) supported (OK) Secure Client-Initiated Renegotiation not vulnerable (OK) CRIME, TLS (CVE-2012-4929) not vulnerable (OK) BREACH (CVE-2013-3587) potentially NOT ok, "br gzip" HTTP compression detected. - only supplied "/" tested Can be ignored for static pages or if no secrets in the page POODLE, SSL (CVE-2014-3566) not vulnerable (OK) TLS_FALLBACK_SCSV (RFC 7507) No fallback possible (OK), no protocol below TLS 1.2 offered SWEET32 (CVE-2016-2183, CVE-2016-6329) not vulnerable (OK) FREAK (CVE-2015-0204) not vulnerable (OK) DROWN (CVE-2016-0800, CVE-2016-0703) not vulnerable on this host and port (OK) make sure you don't use this certificate elsewhere with SSLv2 enabled services, see https://search.censys.io/search?resource=hosts&virtual_hosts=INCLUDE&q=96349848BC554EA65EC53A8252AD1D3F6BEBCABBD5A91BA6EE0C7F81A626AC84 LOGJAM (CVE-2015-4000), experimental not vulnerable (OK): no DH EXPORT ciphers, no DH key detected with <= TLS 1.2 BEAST (CVE-2011-3389) not vulnerable (OK), no SSL3 or TLS1 LUCKY13 (CVE-2013-0169), experimental potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs. Winshock (CVE-2014-6321), experimental not vulnerable (OK) RC4 (CVE-2013-2566, CVE-2015-2808) no RC4 ciphers detected (OK) Done 2026-09-20 15:01:17 [ 232s] -->> 99.86.77.88:443 (privacy.reverso.net) <<-- ----------------------------------------------------- Start 2026-09-20 15:01:17 -->> 99.86.77.72:443 (privacy.reverso.net) <<-- Further IP addresses: 99.86.77.121 99.86.77.101 99.86.77.88 rDNS (99.86.77.72): server-99-86-77-72.ord56.r.cloudfront.net. Service detected: HTTP Testing for server implementation bugs No bugs found. Testing HTTP header response @ "/" HTTP Status Code 200 OK HTTP clock skew +1 sec from localtime HTTP Age (RFC 7234) 3590 Strict Transport Security not offered Public Key Pinning -- Server banner AmazonS3 Application banner -- Cookie(s) (none issued at "/") Security headers Cache-Control: public, max-age=3600 Reverse Proxy banner Via: 1.1 926b5281e2124486e0c9dadab33d1b9c.cloudfront.net (CloudFront), 1.1 1543097fda03aa32e85e0b3ff1853d24.cloudfront.net (CloudFront) X-Cache: Miss from cloudfront Testing vulnerabilities Secure Renegotiation (RFC 5746) supported (OK) Secure Client-Initiated Renegotiation not vulnerable (OK) CRIME, TLS (CVE-2012-4929) not vulnerable (OK) BREACH (CVE-2013-3587) potentially NOT ok, "br gzip" HTTP compression detected. - only supplied "/" tested Can be ignored for static pages or if no secrets in the page POODLE, SSL (CVE-2014-3566) not vulnerable (OK) TLS_FALLBACK_SCSV (RFC 7507) No fallback possible (OK), no protocol below TLS 1.2 offered SWEET32 (CVE-2016-2183, CVE-2016-6329) not vulnerable (OK) FREAK (CVE-2015-0204) not vulnerable (OK) DROWN (CVE-2016-0800, CVE-2016-0703) not vulnerable on this host and port (OK) make sure you don't use this certificate elsewhere with SSLv2 enabled services, see https://search.censys.io/search?resource=hosts&virtual_hosts=INCLUDE&q=96349848BC554EA65EC53A8252AD1D3F6BEBCABBD5A91BA6EE0C7F81A626AC84 LOGJAM (CVE-2015-4000), experimental not vulnerable (OK): no DH EXPORT ciphers, no DH key detected with <= TLS 1.2 BEAST (CVE-2011-3389) not vulnerable (OK), no SSL3 or TLS1 LUCKY13 (CVE-2013-0169), experimental potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs. Winshock (CVE-2014-6321), experimental not vulnerable (OK) RC4 (CVE-2013-2566, CVE-2015-2808) no RC4 ciphers detected (OK) Done 2026-09-20 15:02:29 [ 304s] -->> 99.86.77.72:443 (privacy.reverso.net) <<-- ----------------------------------------------------- Done testing now all IP addresses (on port 443): 99.86.77.121 99.86.77.101 99.86.77.88 99.86.77.72
About this Scan
This scan uses testssl.sh to check for:
- Protocols: SSLv2, SSLv3, TLS 1.0, TLS 1.1, TLS 1.2, TLS 1.3
- Vulnerabilities: Heartbleed, POODLE, FREAK, Logjam, DROWN, etc.
- Cipher Suites: Weak ciphers, perfect forward secrecy (PFS) support.