Deep SSL/TLS Vulnerability Test
This report provides a deep analysis of the SSL/TLS configuration of idcdn.de. It checks for protocol support, cipher strength, and known vulnerabilities.
Scan Results
Testing all IP addresses (port 443): 91.234.30.145 91.234.30.177 91.234.30.146 ----------------------------------------------------- Start 2026-10-13 01:42:27 -->> 91.234.30.145:443 (idcdn.de) <<-- Further IP addresses: 91.234.30.146 91.234.30.177 rDNS (91.234.30.145): -- Service detected: HTTP Testing for server implementation bugs No bugs found. Testing HTTP header response @ "/" HTTP Status Code 404 Not Found (Hint: supply a path which doesn't give a "404 Not Found") HTTP clock skew 0 sec from localtime HTTP Age (RFC 7234) 1 Strict Transport Security not offered Public Key Pinning -- Server banner nginx Application banner -- Cookie(s) 2 issued: NONE secure, NONE HttpOnly -- HTTP status 404 signals you maybe missed the web application Security headers -- Reverse Proxy banner X-Varnish: 588389484 586085718 Via: 1.1 varnish-v4 X-Cache: HIT X-Cache-Hits: 1 Testing vulnerabilities Secure Renegotiation (RFC 5746) supported (OK) Secure Client-Initiated Renegotiation not vulnerable (OK) CRIME, TLS (CVE-2012-4929) not vulnerable (OK) BREACH (CVE-2013-3587) potentially NOT ok, "gzip" HTTP compression detected. - only supplied "/" tested Can be ignored for static pages or if no secrets in the page POODLE, SSL (CVE-2014-3566) not vulnerable (OK) TLS_FALLBACK_SCSV (RFC 7507) No fallback possible (OK), no protocol below TLS 1.2 offered SWEET32 (CVE-2016-2183, CVE-2016-6329) not vulnerable (OK) FREAK (CVE-2015-0204) not vulnerable (OK) DROWN (CVE-2016-0800, CVE-2016-0703) not vulnerable on this host and port (OK) make sure you don't use this certificate elsewhere with SSLv2 enabled services, see https://search.censys.io/search?resource=hosts&virtual_hosts=INCLUDE&q=C88A1329980333EADD03F4136940917BF40CF940986F4A11FB0ABE739AF41881 LOGJAM (CVE-2015-4000), experimental not vulnerable (OK): no DH EXPORT ciphers, no common prime detected BEAST (CVE-2011-3389) not vulnerable (OK), no SSL3 or TLS1 LUCKY13 (CVE-2013-0169), experimental potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs. Winshock (CVE-2014-6321), experimental not vulnerable (OK) RC4 (CVE-2013-2566, CVE-2015-2808) no RC4 ciphers detected (OK) Done 2026-10-13 01:43:45 [ 85s] -->> 91.234.30.145:443 (idcdn.de) <<-- ----------------------------------------------------- Start 2026-10-13 01:43:45 -->> 91.234.30.177:443 (idcdn.de) <<-- Further IP addresses: 91.234.30.146 91.234.30.145 rDNS (91.234.30.177): -- Service detected: HTTP Testing for server implementation bugs No bugs found. Testing HTTP header response @ "/" HTTP Status Code 404 Not Found (Hint: supply a path which doesn't give a "404 Not Found") HTTP clock skew 0 sec from localtime HTTP Age (RFC 7234) 0 Strict Transport Security not offered Public Key Pinning -- Server banner nginx Application banner -- Cookie(s) 2 issued: NONE secure, NONE HttpOnly -- HTTP status 404 signals you maybe missed the web application Security headers -- Reverse Proxy banner X-Varnish: 354485854 350593827 Via: 1.1 varnish-v4 X-Cache: HIT X-Cache-Hits: 1 Testing vulnerabilities Secure Renegotiation (RFC 5746) supported (OK) Secure Client-Initiated Renegotiation not vulnerable (OK) CRIME, TLS (CVE-2012-4929) not vulnerable (OK) BREACH (CVE-2013-3587) potentially NOT ok, "gzip" HTTP compression detected. - only supplied "/" tested Can be ignored for static pages or if no secrets in the page POODLE, SSL (CVE-2014-3566) not vulnerable (OK) TLS_FALLBACK_SCSV (RFC 7507) No fallback possible (OK), no protocol below TLS 1.2 offered SWEET32 (CVE-2016-2183, CVE-2016-6329) not vulnerable (OK) FREAK (CVE-2015-0204) not vulnerable (OK) DROWN (CVE-2016-0800, CVE-2016-0703) not vulnerable on this host and port (OK) make sure you don't use this certificate elsewhere with SSLv2 enabled services, see https://search.censys.io/search?resource=hosts&virtual_hosts=INCLUDE&q=C88A1329980333EADD03F4136940917BF40CF940986F4A11FB0ABE739AF41881 LOGJAM (CVE-2015-4000), experimental not vulnerable (OK): no DH EXPORT ciphers, no common prime detected BEAST (CVE-2011-3389) not vulnerable (OK), no SSL3 or TLS1 LUCKY13 (CVE-2013-0169), experimental potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs. Winshock (CVE-2014-6321), experimental not vulnerable (OK) RC4 (CVE-2013-2566, CVE-2015-2808) no RC4 ciphers detected (OK) Done 2026-10-13 01:45:10 [ 171s] -->> 91.234.30.177:443 (idcdn.de) <<-- ----------------------------------------------------- Start 2026-10-13 01:45:10 -->> 91.234.30.146:443 (idcdn.de) <<-- Further IP addresses: 91.234.30.145 91.234.30.177 rDNS (91.234.30.146): -- Service detected: HTTP Testing for server implementation bugs No bugs found. Testing HTTP header response @ "/" HTTP Status Code 404 Not Found (Hint: supply a path which doesn't give a "404 Not Found") HTTP clock skew +1 sec from localtime HTTP Age (RFC 7234) 1 Strict Transport Security not offered Public Key Pinning -- Server banner nginx Application banner -- Cookie(s) 2 issued: NONE secure, NONE HttpOnly -- HTTP status 404 signals you maybe missed the web application Security headers -- Reverse Proxy banner X-Varnish: 476270194 480187684 Via: 1.1 varnish-v4 X-Cache: HIT X-Cache-Hits: 1 Testing vulnerabilities Secure Renegotiation (RFC 5746) supported (OK) Secure Client-Initiated Renegotiation not vulnerable (OK) CRIME, TLS (CVE-2012-4929) not vulnerable (OK) BREACH (CVE-2013-3587) potentially NOT ok, "gzip" HTTP compression detected. - only supplied "/" tested Can be ignored for static pages or if no secrets in the page POODLE, SSL (CVE-2014-3566) not vulnerable (OK) TLS_FALLBACK_SCSV (RFC 7507) No fallback possible (OK), no protocol below TLS 1.2 offered SWEET32 (CVE-2016-2183, CVE-2016-6329) not vulnerable (OK) FREAK (CVE-2015-0204) not vulnerable (OK) DROWN (CVE-2016-0800, CVE-2016-0703) not vulnerable on this host and port (OK) make sure you don't use this certificate elsewhere with SSLv2 enabled services, see https://search.censys.io/search?resource=hosts&virtual_hosts=INCLUDE&q=C88A1329980333EADD03F4136940917BF40CF940986F4A11FB0ABE739AF41881 LOGJAM (CVE-2015-4000), experimental not vulnerable (OK): no DH EXPORT ciphers, no common prime detected BEAST (CVE-2011-3389) not vulnerable (OK), no SSL3 or TLS1 LUCKY13 (CVE-2013-0169), experimental potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs. Winshock (CVE-2014-6321), experimental not vulnerable (OK) RC4 (CVE-2013-2566, CVE-2015-2808) no RC4 ciphers detected (OK) Done 2026-10-13 01:46:33 [ 254s] -->> 91.234.30.146:443 (idcdn.de) <<-- ----------------------------------------------------- Done testing now all IP addresses (on port 443): 91.234.30.145 91.234.30.177 91.234.30.146
About this Scan
This scan uses testssl.sh to check for:
- Protocols: SSLv2, SSLv3, TLS 1.0, TLS 1.1, TLS 1.2, TLS 1.3
- Vulnerabilities: Heartbleed, POODLE, FREAK, Logjam, DROWN, etc.
- Cipher Suites: Weak ciphers, perfect forward secrecy (PFS) support.