Deep SSL/TLS Vulnerability Test
This report provides a deep analysis of the SSL/TLS configuration of cdn.aznude.com. It checks for protocol support, cipher strength, and known vulnerabilities.
Scan Results
Testing all IP addresses (port 443): 195.181.170.18 195.181.175.40 212.102.56.178 37.19.194.80 79.127.216.203 79.127.211.90 ----------------------------------------------------- Start 2026-09-21 12:44:38 -->> 195.181.170.18:443 (cdn.aznude.com) <<-- Further IP addresses: 79.127.211.90 195.181.175.40 212.102.56.178 37.19.194.80 79.127.216.203 2a02:6ea0:c77a::47 2a02:6ea0:c77a::48 2a02:6ea0:c700::101 2a02:6ea0:c700::21 2a02:6ea0:c700::19 2a02:6ea0:c700::11 rDNS (195.181.170.18): 610407756.fra.cdn77.com. Service detected: HTTP Testing for server implementation bugs No bugs found. Testing HTTP header response @ "/" HTTP Status Code 200 OK HTTP clock skew +609866 sec from localtime HTTP Age (RFC 7234) 609866 Strict Transport Security not offered Public Key Pinning -- Server banner CDN77-Turbo Application banner -- Cookie(s) (none issued at "/") Security headers Access-Control-Allow-Origin: * Reverse Proxy banner -- Testing vulnerabilities Secure Renegotiation (RFC 5746) supported (OK) Secure Client-Initiated Renegotiation not vulnerable (OK) CRIME, TLS (CVE-2012-4929) not vulnerable (OK) BREACH (CVE-2013-3587) potentially NOT ok, "gzip" HTTP compression detected. - only supplied "/" tested Can be ignored for static pages or if no secrets in the page POODLE, SSL (CVE-2014-3566) not vulnerable (OK) TLS_FALLBACK_SCSV (RFC 7507) No fallback possible (OK), no protocol below TLS 1.2 offered SWEET32 (CVE-2016-2183, CVE-2016-6329) not vulnerable (OK) FREAK (CVE-2015-0204) not vulnerable (OK) DROWN (CVE-2016-0800, CVE-2016-0703) not vulnerable on this host and port (OK) no RSA certificate, thus certificate can't be used with SSLv2 elsewhere LOGJAM (CVE-2015-4000), experimental not vulnerable (OK): no DH EXPORT ciphers, no DH key detected with <= TLS 1.2 BEAST (CVE-2011-3389) not vulnerable (OK), no SSL3 or TLS1 LUCKY13 (CVE-2013-0169), experimental potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs. Winshock (CVE-2014-6321), experimental not vulnerable (OK) RC4 (CVE-2013-2566, CVE-2015-2808) no RC4 ciphers detected (OK) Done 2026-09-21 12:45:50 [ 81s] -->> 195.181.170.18:443 (cdn.aznude.com) <<-- ----------------------------------------------------- Start 2026-09-21 12:45:50 -->> 195.181.175.40:443 (cdn.aznude.com) <<-- Further IP addresses: 79.127.211.90 195.181.170.18 212.102.56.178 37.19.194.80 79.127.216.203 2a02:6ea0:c77a::47 2a02:6ea0:c77a::48 2a02:6ea0:c700::101 2a02:6ea0:c700::21 2a02:6ea0:c700::19 2a02:6ea0:c700::11 rDNS (195.181.175.40): 824291365.fra.cdn77.com. Service detected: HTTP Testing for server implementation bugs No bugs found. Testing HTTP header response @ "/" HTTP Status Code 200 OK HTTP clock skew +609944 sec from localtime HTTP Age (RFC 7234) 609944 Strict Transport Security not offered Public Key Pinning -- Server banner CDN77-Turbo Application banner -- Cookie(s) (none issued at "/") Security headers Access-Control-Allow-Origin: * Reverse Proxy banner -- Testing vulnerabilities Secure Renegotiation (RFC 5746) supported (OK) Secure Client-Initiated Renegotiation not vulnerable (OK) CRIME, TLS (CVE-2012-4929) not vulnerable (OK) BREACH (CVE-2013-3587) potentially NOT ok, "gzip" HTTP compression detected. - only supplied "/" tested Can be ignored for static pages or if no secrets in the page POODLE, SSL (CVE-2014-3566) not vulnerable (OK) TLS_FALLBACK_SCSV (RFC 7507) No fallback possible (OK), no protocol below TLS 1.2 offered SWEET32 (CVE-2016-2183, CVE-2016-6329) not vulnerable (OK) FREAK (CVE-2015-0204) not vulnerable (OK) DROWN (CVE-2016-0800, CVE-2016-0703) not vulnerable on this host and port (OK) no RSA certificate, thus certificate can't be used with SSLv2 elsewhere LOGJAM (CVE-2015-4000), experimental not vulnerable (OK): no DH EXPORT ciphers, no DH key detected with <= TLS 1.2 BEAST (CVE-2011-3389) not vulnerable (OK), no SSL3 or TLS1 LUCKY13 (CVE-2013-0169), experimental potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs. Winshock (CVE-2014-6321), experimental not vulnerable (OK) RC4 (CVE-2013-2566, CVE-2015-2808) no RC4 ciphers detected (OK) Done 2026-09-21 12:47:07 [ 158s] -->> 195.181.175.40:443 (cdn.aznude.com) <<-- ----------------------------------------------------- Start 2026-09-21 12:47:08 -->> 212.102.56.178:443 (cdn.aznude.com) <<-- Further IP addresses: 79.127.211.90 195.181.170.18 195.181.175.40 37.19.194.80 79.127.216.203 2a02:6ea0:c77a::47 2a02:6ea0:c77a::48 2a02:6ea0:c700::101 2a02:6ea0:c700::21 2a02:6ea0:c700::19 2a02:6ea0:c700::11 rDNS (212.102.56.178): 245149724.fra.cdn77.com. Service detected: HTTP Testing for server implementation bugs No bugs found. Testing HTTP header response @ "/" HTTP Status Code 200 OK HTTP clock skew +610014 sec from localtime HTTP Age (RFC 7234) 610014 Strict Transport Security not offered Public Key Pinning -- Server banner CDN77-Turbo Application banner -- Cookie(s) (none issued at "/") Security headers Access-Control-Allow-Origin: * Reverse Proxy banner -- Testing vulnerabilities Secure Renegotiation (RFC 5746) supported (OK) Secure Client-Initiated Renegotiation not vulnerable (OK) CRIME, TLS (CVE-2012-4929) not vulnerable (OK) BREACH (CVE-2013-3587) potentially NOT ok, "gzip" HTTP compression detected. - only supplied "/" tested Can be ignored for static pages or if no secrets in the page POODLE, SSL (CVE-2014-3566) not vulnerable (OK) TLS_FALLBACK_SCSV (RFC 7507) No fallback possible (OK), no protocol below TLS 1.2 offered SWEET32 (CVE-2016-2183, CVE-2016-6329) not vulnerable (OK) FREAK (CVE-2015-0204) not vulnerable (OK) DROWN (CVE-2016-0800, CVE-2016-0703) not vulnerable on this host and port (OK) no RSA certificate, thus certificate can't be used with SSLv2 elsewhere LOGJAM (CVE-2015-4000), experimental not vulnerable (OK): no DH EXPORT ciphers, no DH key detected with <= TLS 1.2 BEAST (CVE-2011-3389) not vulnerable (OK), no SSL3 or TLS1 LUCKY13 (CVE-2013-0169), experimental potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs. Winshock (CVE-2014-6321), experimental not vulnerable (OK) RC4 (CVE-2013-2566, CVE-2015-2808) no RC4 ciphers detected (OK) Done 2026-09-21 12:48:14 [ 225s] -->> 212.102.56.178:443 (cdn.aznude.com) <<-- ----------------------------------------------------- Start 2026-09-21 12:48:14 -->> 37.19.194.80:443 (cdn.aznude.com) <<-- Further IP addresses: 79.127.211.90 195.181.170.18 195.181.175.40 212.102.56.178 79.127.216.203 2a02:6ea0:c77a::47 2a02:6ea0:c77a::48 2a02:6ea0:c700::101 2a02:6ea0:c700::21 2a02:6ea0:c700::19 2a02:6ea0:c700::11 rDNS (37.19.194.80): 413474573.fra.cdn77.com. Service detected: HTTP Testing for server implementation bugs No bugs found. Testing HTTP header response @ "/" HTTP Status Code 200 OK HTTP clock skew +610097 sec from localtime HTTP Age (RFC 7234) 610097 Strict Transport Security not offered Public Key Pinning -- Server banner CDN77-Turbo Application banner -- Cookie(s) (none issued at "/") Security headers Access-Control-Allow-Origin: * Reverse Proxy banner -- Testing vulnerabilities Secure Renegotiation (RFC 5746) supported (OK) Secure Client-Initiated Renegotiation not vulnerable (OK) CRIME, TLS (CVE-2012-4929) not vulnerable (OK) BREACH (CVE-2013-3587) potentially NOT ok, "gzip" HTTP compression detected. - only supplied "/" tested Can be ignored for static pages or if no secrets in the page POODLE, SSL (CVE-2014-3566) not vulnerable (OK) TLS_FALLBACK_SCSV (RFC 7507) No fallback possible (OK), no protocol below TLS 1.2 offered SWEET32 (CVE-2016-2183, CVE-2016-6329) not vulnerable (OK) FREAK (CVE-2015-0204) not vulnerable (OK) DROWN (CVE-2016-0800, CVE-2016-0703) not vulnerable on this host and port (OK) no RSA certificate, thus certificate can't be used with SSLv2 elsewhere LOGJAM (CVE-2015-4000), experimental not vulnerable (OK): no DH EXPORT ciphers, no DH key detected with <= TLS 1.2 BEAST (CVE-2011-3389) not vulnerable (OK), no SSL3 or TLS1 LUCKY13 (CVE-2013-0169), experimental potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs. Winshock (CVE-2014-6321), experimental not vulnerable (OK) RC4 (CVE-2013-2566, CVE-2015-2808) no RC4 ciphers detected (OK) Done 2026-09-21 12:49:34 [ 305s] -->> 37.19.194.80:443 (cdn.aznude.com) <<-- ----------------------------------------------------- Start 2026-09-21 12:49:34 -->> 79.127.216.203:443 (cdn.aznude.com) <<-- Further IP addresses: 79.127.211.90 195.181.170.18 195.181.175.40 212.102.56.178 37.19.194.80 2a02:6ea0:c77a::47 2a02:6ea0:c77a::48 2a02:6ea0:c700::101 2a02:6ea0:c700::21 2a02:6ea0:c700::19 2a02:6ea0:c700::11 rDNS (79.127.216.203): 651293913.fra.cdn77.com. Service detected: HTTP Testing for server implementation bugs No bugs found. Testing HTTP header response @ "/" HTTP Status Code 200 OK HTTP clock skew +610171 sec from localtime HTTP Age (RFC 7234) 610171 Strict Transport Security not offered Public Key Pinning -- Server banner CDN77-Turbo Application banner -- Cookie(s) (none issued at "/") Security headers Access-Control-Allow-Origin: * Reverse Proxy banner -- Testing vulnerabilities Secure Renegotiation (RFC 5746) supported (OK) Secure Client-Initiated Renegotiation not vulnerable (OK) CRIME, TLS (CVE-2012-4929) not vulnerable (OK) BREACH (CVE-2013-3587) potentially NOT ok, "gzip" HTTP compression detected. - only supplied "/" tested Can be ignored for static pages or if no secrets in the page POODLE, SSL (CVE-2014-3566) not vulnerable (OK) TLS_FALLBACK_SCSV (RFC 7507) No fallback possible (OK), no protocol below TLS 1.2 offered SWEET32 (CVE-2016-2183, CVE-2016-6329) not vulnerable (OK) FREAK (CVE-2015-0204) not vulnerable (OK) DROWN (CVE-2016-0800, CVE-2016-0703) not vulnerable on this host and port (OK) no RSA certificate, thus certificate can't be used with SSLv2 elsewhere LOGJAM (CVE-2015-4000), experimental not vulnerable (OK): no DH EXPORT ciphers, no DH key detected with <= TLS 1.2 BEAST (CVE-2011-3389) not vulnerable (OK), no SSL3 or TLS1 LUCKY13 (CVE-2013-0169), experimental potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs. Winshock (CVE-2014-6321), experimental not vulnerable (OK) RC4 (CVE-2013-2566, CVE-2015-2808) no RC4 ciphers detected (OK) Done 2026-09-21 12:50:55 [ 386s] -->> 79.127.216.203:443 (cdn.aznude.com) <<-- ----------------------------------------------------- Start 2026-09-21 12:50:55 -->> 79.127.211.90:443 (cdn.aznude.com) <<-- Further IP addresses: 195.181.170.18 195.181.175.40 212.102.56.178 37.19.194.80 79.127.216.203 2a02:6ea0:c77a::47 2a02:6ea0:c77a::48 2a02:6ea0:c700::101 2a02:6ea0:c700::21 2a02:6ea0:c700::19 2a02:6ea0:c700::11 rDNS (79.127.211.90): 787975672.fra.cdn77.com. Service detected: HTTP Testing for server implementation bugs No bugs found. Testing HTTP header response @ "/" HTTP Status Code 200 OK HTTP clock skew +610246 sec from localtime HTTP Age (RFC 7234) 610246 Strict Transport Security not offered Public Key Pinning -- Server banner CDN77-Turbo Application banner -- Cookie(s) (none issued at "/") Security headers Access-Control-Allow-Origin: * Reverse Proxy banner -- Testing vulnerabilities Secure Renegotiation (RFC 5746) supported (OK) Secure Client-Initiated Renegotiation not vulnerable (OK) CRIME, TLS (CVE-2012-4929) not vulnerable (OK) BREACH (CVE-2013-3587) potentially NOT ok, "gzip" HTTP compression detected. - only supplied "/" tested Can be ignored for static pages or if no secrets in the page POODLE, SSL (CVE-2014-3566) not vulnerable (OK) TLS_FALLBACK_SCSV (RFC 7507) No fallback possible (OK), no protocol below TLS 1.2 offered SWEET32 (CVE-2016-2183, CVE-2016-6329) not vulnerable (OK) FREAK (CVE-2015-0204) not vulnerable (OK) DROWN (CVE-2016-0800, CVE-2016-0703) not vulnerable on this host and port (OK) no RSA certificate, thus certificate can't be used with SSLv2 elsewhere LOGJAM (CVE-2015-4000), experimental not vulnerable (OK): no DH EXPORT ciphers, no DH key detected with <= TLS 1.2 BEAST (CVE-2011-3389) not vulnerable (OK), no SSL3 or TLS1 LUCKY13 (CVE-2013-0169), experimental potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs. Winshock (CVE-2014-6321), experimental not vulnerable (OK) RC4 (CVE-2013-2566, CVE-2015-2808) no RC4 ciphers detected (OK) Done 2026-09-21 12:52:10 [ 461s] -->> 79.127.211.90:443 (cdn.aznude.com) <<-- ----------------------------------------------------- Done testing now all IP addresses (on port 443): 195.181.170.18 195.181.175.40 212.102.56.178 37.19.194.80 79.127.216.203 79.127.211.90
About this Scan
This scan uses testssl.sh to check for:
- Protocols: SSLv2, SSLv3, TLS 1.0, TLS 1.1, TLS 1.2, TLS 1.3
- Vulnerabilities: Heartbleed, POODLE, FREAK, Logjam, DROWN, etc.
- Cipher Suites: Weak ciphers, perfect forward secrecy (PFS) support.