Deep SSL/TLS Vulnerability Test
This report provides a deep analysis of the SSL/TLS configuration of assets.hearstapps.com. It checks for protocol support, cipher strength, and known vulnerabilities.
Scan Results
Testing all IP addresses (port 443): 151.101.0.155 151.101.128.155 151.101.192.155 151.101.64.155 ----------------------------------------------------- Start 2026-10-18 23:44:01 -->> 151.101.0.155:443 (assets.hearstapps.com) <<-- Further IP addresses: 151.101.64.155 151.101.128.155 151.101.192.155 rDNS (151.101.0.155): -- Service detected: HTTP Testing for server implementation bugs No bugs found. Testing HTTP header response @ "/" HTTP Status Code 403 Forbidden HTTP clock skew +2 sec from localtime HTTP Age (RFC 7234) 2 Strict Transport Security not offered Public Key Pinning -- Server banner (no "Server" line in header, interesting!) Application banner -- Cookie(s) (none issued at "/") -- HTTP status 403 signals you maybe missed the web application Security headers Access-Control-Allow-Origin: * Cache-Control: max-age=5 Reverse Proxy banner X-Cache: MISS, HIT, HIT Testing vulnerabilities Secure Renegotiation (RFC 5746) supported (OK) Secure Client-Initiated Renegotiation not vulnerable (OK) CRIME, TLS (CVE-2012-4929) not vulnerable (OK) BREACH (CVE-2013-3587) no gzip/deflate/compress/br HTTP compression (OK) - only supplied "/" tested POODLE, SSL (CVE-2014-3566) not vulnerable (OK) TLS_FALLBACK_SCSV (RFC 7507) No fallback possible (OK), no protocol below TLS 1.2 offered SWEET32 (CVE-2016-2183, CVE-2016-6329) not vulnerable (OK) FREAK (CVE-2015-0204) not vulnerable (OK) DROWN (CVE-2016-0800, CVE-2016-0703) not vulnerable on this host and port (OK) make sure you don't use this certificate elsewhere with SSLv2 enabled services, see https://search.censys.io/search?resource=hosts&virtual_hosts=INCLUDE&q=ABB23F1CF19C0F3F9129A545B435C11CBDF4BD3A1534EA32AD1F3F3F7FDD9228 LOGJAM (CVE-2015-4000), experimental not vulnerable (OK): no DH EXPORT ciphers, no DH key detected with <= TLS 1.2 BEAST (CVE-2011-3389) not vulnerable (OK), no SSL3 or TLS1 LUCKY13 (CVE-2013-0169), experimental potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs. Winshock (CVE-2014-6321), experimental not vulnerable (OK) RC4 (CVE-2013-2566, CVE-2015-2808) no RC4 ciphers detected (OK) Done 2026-10-18 23:44:46 [ 54s] -->> 151.101.0.155:443 (assets.hearstapps.com) <<-- ----------------------------------------------------- Start 2026-10-18 23:44:46 -->> 151.101.128.155:443 (assets.hearstapps.com) <<-- Further IP addresses: 151.101.64.155 151.101.0.155 151.101.192.155 rDNS (151.101.128.155): -- Service detected: HTTP Testing for server implementation bugs No bugs found. Testing HTTP header response @ "/" HTTP Status Code 403 Forbidden HTTP clock skew +1 sec from localtime HTTP Age (RFC 7234) 1 Strict Transport Security not offered Public Key Pinning -- Server banner (no "Server" line in header, interesting!) Application banner -- Cookie(s) (none issued at "/") -- HTTP status 403 signals you maybe missed the web application Security headers Access-Control-Allow-Origin: * Cache-Control: max-age=5 Reverse Proxy banner X-Cache: MISS, MISS, HIT Testing vulnerabilities Secure Renegotiation (RFC 5746) supported (OK) Secure Client-Initiated Renegotiation not vulnerable (OK) CRIME, TLS (CVE-2012-4929) not vulnerable (OK) BREACH (CVE-2013-3587) no gzip/deflate/compress/br HTTP compression (OK) - only supplied "/" tested POODLE, SSL (CVE-2014-3566) not vulnerable (OK) TLS_FALLBACK_SCSV (RFC 7507) No fallback possible (OK), no protocol below TLS 1.2 offered SWEET32 (CVE-2016-2183, CVE-2016-6329) not vulnerable (OK) FREAK (CVE-2015-0204) not vulnerable (OK) DROWN (CVE-2016-0800, CVE-2016-0703) not vulnerable on this host and port (OK) make sure you don't use this certificate elsewhere with SSLv2 enabled services, see https://search.censys.io/search?resource=hosts&virtual_hosts=INCLUDE&q=ABB23F1CF19C0F3F9129A545B435C11CBDF4BD3A1534EA32AD1F3F3F7FDD9228 LOGJAM (CVE-2015-4000), experimental not vulnerable (OK): no DH EXPORT ciphers, no DH key detected with <= TLS 1.2 BEAST (CVE-2011-3389) not vulnerable (OK), no SSL3 or TLS1 LUCKY13 (CVE-2013-0169), experimental potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs. Winshock (CVE-2014-6321), experimental not vulnerable (OK) RC4 (CVE-2013-2566, CVE-2015-2808) no RC4 ciphers detected (OK) Done 2026-10-18 23:45:36 [ 104s] -->> 151.101.128.155:443 (assets.hearstapps.com) <<-- ----------------------------------------------------- Start 2026-10-18 23:45:36 -->> 151.101.192.155:443 (assets.hearstapps.com) <<-- Further IP addresses: 151.101.64.155 151.101.0.155 151.101.128.155 rDNS (151.101.192.155): -- Service detected: HTTP Testing for server implementation bugs No bugs found. Testing HTTP header response @ "/" HTTP Status Code 403 Forbidden HTTP clock skew +1 sec from localtime HTTP Age (RFC 7234) 1 Strict Transport Security not offered Public Key Pinning -- Server banner (no "Server" line in header, interesting!) Application banner -- Cookie(s) (none issued at "/") -- HTTP status 403 signals you maybe missed the web application Security headers Access-Control-Allow-Origin: * Cache-Control: max-age=5 Reverse Proxy banner X-Cache: MISS, MISS, HIT Testing vulnerabilities Secure Renegotiation (RFC 5746) supported (OK) Secure Client-Initiated Renegotiation not vulnerable (OK) CRIME, TLS (CVE-2012-4929) not vulnerable (OK) BREACH (CVE-2013-3587) no gzip/deflate/compress/br HTTP compression (OK) - only supplied "/" tested POODLE, SSL (CVE-2014-3566) not vulnerable (OK) TLS_FALLBACK_SCSV (RFC 7507) No fallback possible (OK), no protocol below TLS 1.2 offered SWEET32 (CVE-2016-2183, CVE-2016-6329) not vulnerable (OK) FREAK (CVE-2015-0204) not vulnerable (OK) DROWN (CVE-2016-0800, CVE-2016-0703) not vulnerable on this host and port (OK) make sure you don't use this certificate elsewhere with SSLv2 enabled services, see https://search.censys.io/search?resource=hosts&virtual_hosts=INCLUDE&q=ABB23F1CF19C0F3F9129A545B435C11CBDF4BD3A1534EA32AD1F3F3F7FDD9228 LOGJAM (CVE-2015-4000), experimental not vulnerable (OK): no DH EXPORT ciphers, no DH key detected with <= TLS 1.2 BEAST (CVE-2011-3389) not vulnerable (OK), no SSL3 or TLS1 LUCKY13 (CVE-2013-0169), experimental potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs. Winshock (CVE-2014-6321), experimental not vulnerable (OK) RC4 (CVE-2013-2566, CVE-2015-2808) no RC4 ciphers detected (OK) Done 2026-10-18 23:46:31 [ 159s] -->> 151.101.192.155:443 (assets.hearstapps.com) <<-- ----------------------------------------------------- Start 2026-10-18 23:46:31 -->> 151.101.64.155:443 (assets.hearstapps.com) <<-- Further IP addresses: 151.101.0.155 151.101.128.155 151.101.192.155 rDNS (151.101.64.155): -- Service detected: HTTP Testing for server implementation bugs No bugs found. Testing HTTP header response @ "/" HTTP Status Code 403 Forbidden HTTP clock skew +1 sec from localtime HTTP Age (RFC 7234) 1 Strict Transport Security not offered Public Key Pinning -- Server banner (no "Server" line in header, interesting!) Application banner -- Cookie(s) (none issued at "/") -- HTTP status 403 signals you maybe missed the web application Security headers Access-Control-Allow-Origin: * Cache-Control: max-age=5 Reverse Proxy banner X-Cache: MISS, MISS, HIT Testing vulnerabilities Secure Renegotiation (RFC 5746) supported (OK) Secure Client-Initiated Renegotiation not vulnerable (OK) CRIME, TLS (CVE-2012-4929) not vulnerable (OK) BREACH (CVE-2013-3587) no gzip/deflate/compress/br HTTP compression (OK) - only supplied "/" tested POODLE, SSL (CVE-2014-3566) not vulnerable (OK) TLS_FALLBACK_SCSV (RFC 7507) No fallback possible (OK), no protocol below TLS 1.2 offered SWEET32 (CVE-2016-2183, CVE-2016-6329) not vulnerable (OK) FREAK (CVE-2015-0204) not vulnerable (OK) DROWN (CVE-2016-0800, CVE-2016-0703) not vulnerable on this host and port (OK) make sure you don't use this certificate elsewhere with SSLv2 enabled services, see https://search.censys.io/search?resource=hosts&virtual_hosts=INCLUDE&q=ABB23F1CF19C0F3F9129A545B435C11CBDF4BD3A1534EA32AD1F3F3F7FDD9228 LOGJAM (CVE-2015-4000), experimental not vulnerable (OK): no DH EXPORT ciphers, no DH key detected with <= TLS 1.2 BEAST (CVE-2011-3389) not vulnerable (OK), no SSL3 or TLS1 LUCKY13 (CVE-2013-0169), experimental potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs. Winshock (CVE-2014-6321), experimental not vulnerable (OK) RC4 (CVE-2013-2566, CVE-2015-2808) no RC4 ciphers detected (OK) Done 2026-10-18 23:47:23 [ 211s] -->> 151.101.64.155:443 (assets.hearstapps.com) <<-- ----------------------------------------------------- Done testing now all IP addresses (on port 443): 151.101.0.155 151.101.128.155 151.101.192.155 151.101.64.155
About this Scan
This scan uses testssl.sh to check for:
- Protocols: SSLv2, SSLv3, TLS 1.0, TLS 1.1, TLS 1.2, TLS 1.3
- Vulnerabilities: Heartbleed, POODLE, FREAK, Logjam, DROWN, etc.
- Cipher Suites: Weak ciphers, perfect forward secrecy (PFS) support.