Deep SSL/TLS Vulnerability Test
This report provides a deep analysis of the SSL/TLS configuration of assets-jpcust.jwpsrv.com. It checks for protocol support, cipher strength, and known vulnerabilities.
Scan Results
Testing all IP addresses (port 443): 151.101.66.114 151.101.130.114 151.101.2.114 151.101.194.114 ----------------------------------------------------- Start 2026-10-20 03:56:16 -->> 151.101.66.114:443 (assets-jpcust.jwpsrv.com) <<-- Further IP addresses: 151.101.194.114 151.101.130.114 151.101.2.114 2a04:4e42::626 2a04:4e42:400::626 2a04:4e42:200::626 2a04:4e42:600::626 rDNS (151.101.66.114): -- Service detected: HTTP Testing for server implementation bugs No bugs found. Testing HTTP header response @ "/" HTTP Status Code 404 Not Found (Hint: supply a path which doesn't give a "404 Not Found") HTTP clock skew +20 sec from localtime HTTP Age (RFC 7234) 20 Strict Transport Security not offered Public Key Pinning -- Server banner nginx Application banner -- Cookie(s) (none issued at "/") -- HTTP status 404 signals you maybe missed the web application Security headers Access-Control-Allow-Origin: * X-Served-By: cache-iad-kcgs7200047-IAD, cache-chi-klot8100031-CHI Reverse Proxy banner Via: 1.1 varnish, 1.1 varnish X-Cache: HIT, HIT X-Cache-Hits: 2, 1 Testing vulnerabilities Secure Renegotiation (RFC 5746) supported (OK) Secure Client-Initiated Renegotiation not vulnerable (OK) CRIME, TLS (CVE-2012-4929) not vulnerable (OK) BREACH (CVE-2013-3587) potentially NOT ok, "gzip" HTTP compression detected. - only supplied "/" tested Can be ignored for static pages or if no secrets in the page POODLE, SSL (CVE-2014-3566) not vulnerable (OK) TLS_FALLBACK_SCSV (RFC 7507) No fallback possible (OK), no protocol below TLS 1.2 offered SWEET32 (CVE-2016-2183, CVE-2016-6329) not vulnerable (OK) FREAK (CVE-2015-0204) not vulnerable (OK) DROWN (CVE-2016-0800, CVE-2016-0703) not vulnerable on this host and port (OK) make sure you don't use this certificate elsewhere with SSLv2 enabled services, see https://search.censys.io/search?resource=hosts&virtual_hosts=INCLUDE&q=EE310C950635EF36ECB6C013BDFBD96C757BC074D88C0344B948429F26BBF94A LOGJAM (CVE-2015-4000), experimental not vulnerable (OK): no DH EXPORT ciphers, no DH key detected with <= TLS 1.2 BEAST (CVE-2011-3389) not vulnerable (OK), no SSL3 or TLS1 LUCKY13 (CVE-2013-0169), experimental potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs. Winshock (CVE-2014-6321), experimental not vulnerable (OK) RC4 (CVE-2013-2566, CVE-2015-2808) no RC4 ciphers detected (OK) Done 2026-10-20 03:56:54 [ 46s] -->> 151.101.66.114:443 (assets-jpcust.jwpsrv.com) <<-- ----------------------------------------------------- Start 2026-10-20 03:56:54 -->> 151.101.130.114:443 (assets-jpcust.jwpsrv.com) <<-- Further IP addresses: 151.101.194.114 151.101.66.114 151.101.2.114 2a04:4e42::626 2a04:4e42:400::626 2a04:4e42:200::626 2a04:4e42:600::626 rDNS (151.101.130.114): -- Service detected: HTTP Testing for server implementation bugs No bugs found. Testing HTTP header response @ "/" HTTP Status Code 404 Not Found (Hint: supply a path which doesn't give a "404 Not Found") HTTP clock skew +64 sec from localtime HTTP Age (RFC 7234) 64 Strict Transport Security not offered Public Key Pinning -- Server banner nginx Application banner -- Cookie(s) (none issued at "/") -- HTTP status 404 signals you maybe missed the web application Security headers Access-Control-Allow-Origin: * X-Served-By: cache-iad-kcgs7200047-IAD, cache-chi-klot8100109-CHI Reverse Proxy banner Via: 1.1 varnish, 1.1 varnish X-Cache: HIT, HIT X-Cache-Hits: 2, 1 Testing vulnerabilities Secure Renegotiation (RFC 5746) supported (OK) Secure Client-Initiated Renegotiation not vulnerable (OK) CRIME, TLS (CVE-2012-4929) not vulnerable (OK) BREACH (CVE-2013-3587) potentially NOT ok, "gzip" HTTP compression detected. - only supplied "/" tested Can be ignored for static pages or if no secrets in the page POODLE, SSL (CVE-2014-3566) not vulnerable (OK) TLS_FALLBACK_SCSV (RFC 7507) No fallback possible (OK), no protocol below TLS 1.2 offered SWEET32 (CVE-2016-2183, CVE-2016-6329) not vulnerable (OK) FREAK (CVE-2015-0204) not vulnerable (OK) DROWN (CVE-2016-0800, CVE-2016-0703) not vulnerable on this host and port (OK) make sure you don't use this certificate elsewhere with SSLv2 enabled services, see https://search.censys.io/search?resource=hosts&virtual_hosts=INCLUDE&q=EE310C950635EF36ECB6C013BDFBD96C757BC074D88C0344B948429F26BBF94A LOGJAM (CVE-2015-4000), experimental not vulnerable (OK): no DH EXPORT ciphers, no DH key detected with <= TLS 1.2 BEAST (CVE-2011-3389) not vulnerable (OK), no SSL3 or TLS1 LUCKY13 (CVE-2013-0169), experimental potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs. Winshock (CVE-2014-6321), experimental not vulnerable (OK) RC4 (CVE-2013-2566, CVE-2015-2808) no RC4 ciphers detected (OK) Done 2026-10-20 03:57:38 [ 90s] -->> 151.101.130.114:443 (assets-jpcust.jwpsrv.com) <<-- ----------------------------------------------------- Start 2026-10-20 03:57:38 -->> 151.101.2.114:443 (assets-jpcust.jwpsrv.com) <<-- Further IP addresses: 151.101.194.114 151.101.66.114 151.101.130.114 2a04:4e42::626 2a04:4e42:400::626 2a04:4e42:200::626 2a04:4e42:600::626 rDNS (151.101.2.114): -- Service detected: HTTP Testing for server implementation bugs No bugs found. Testing HTTP header response @ "/" HTTP Status Code 404 Not Found (Hint: supply a path which doesn't give a "404 Not Found") HTTP clock skew +102 sec from localtime HTTP Age (RFC 7234) 102 Strict Transport Security not offered Public Key Pinning -- Server banner nginx Application banner -- Cookie(s) (none issued at "/") -- HTTP status 404 signals you maybe missed the web application Security headers Access-Control-Allow-Origin: * X-Served-By: cache-iad-kcgs7200047-IAD, cache-chi-kigq8000123-CHI Reverse Proxy banner Via: 1.1 varnish, 1.1 varnish X-Cache: HIT, HIT X-Cache-Hits: 2, 1 Testing vulnerabilities Secure Renegotiation (RFC 5746) supported (OK) Secure Client-Initiated Renegotiation not vulnerable (OK) CRIME, TLS (CVE-2012-4929) not vulnerable (OK) BREACH (CVE-2013-3587) potentially NOT ok, "gzip" HTTP compression detected. - only supplied "/" tested Can be ignored for static pages or if no secrets in the page POODLE, SSL (CVE-2014-3566) not vulnerable (OK) TLS_FALLBACK_SCSV (RFC 7507) No fallback possible (OK), no protocol below TLS 1.2 offered SWEET32 (CVE-2016-2183, CVE-2016-6329) not vulnerable (OK) FREAK (CVE-2015-0204) not vulnerable (OK) DROWN (CVE-2016-0800, CVE-2016-0703) not vulnerable on this host and port (OK) make sure you don't use this certificate elsewhere with SSLv2 enabled services, see https://search.censys.io/search?resource=hosts&virtual_hosts=INCLUDE&q=EE310C950635EF36ECB6C013BDFBD96C757BC074D88C0344B948429F26BBF94A LOGJAM (CVE-2015-4000), experimental not vulnerable (OK): no DH EXPORT ciphers, no DH key detected with <= TLS 1.2 BEAST (CVE-2011-3389) not vulnerable (OK), no SSL3 or TLS1 LUCKY13 (CVE-2013-0169), experimental potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs. Winshock (CVE-2014-6321), experimental not vulnerable (OK) RC4 (CVE-2013-2566, CVE-2015-2808) no RC4 ciphers detected (OK) Done 2026-10-20 03:58:16 [ 128s] -->> 151.101.2.114:443 (assets-jpcust.jwpsrv.com) <<-- ----------------------------------------------------- Start 2026-10-20 03:58:16 -->> 151.101.194.114:443 (assets-jpcust.jwpsrv.com) <<-- Further IP addresses: 151.101.66.114 151.101.130.114 151.101.2.114 2a04:4e42::626 2a04:4e42:400::626 2a04:4e42:200::626 2a04:4e42:600::626 rDNS (151.101.194.114): -- Service detected: HTTP Testing for server implementation bugs No bugs found. Testing HTTP header response @ "/" HTTP Status Code 404 Not Found (Hint: supply a path which doesn't give a "404 Not Found") HTTP clock skew +148 sec from localtime HTTP Age (RFC 7234) 148 Strict Transport Security not offered Public Key Pinning -- Server banner nginx Application banner -- Cookie(s) (none issued at "/") -- HTTP status 404 signals you maybe missed the web application Security headers Access-Control-Allow-Origin: * X-Served-By: cache-iad-kcgs7200047-IAD, cache-chi-klot8100079-CHI Reverse Proxy banner Via: 1.1 varnish, 1.1 varnish X-Cache: HIT, HIT X-Cache-Hits: 2, 1 Testing vulnerabilities Secure Renegotiation (RFC 5746) supported (OK) Secure Client-Initiated Renegotiation not vulnerable (OK) CRIME, TLS (CVE-2012-4929) not vulnerable (OK) BREACH (CVE-2013-3587) potentially NOT ok, "gzip" HTTP compression detected. - only supplied "/" tested Can be ignored for static pages or if no secrets in the page POODLE, SSL (CVE-2014-3566) not vulnerable (OK) TLS_FALLBACK_SCSV (RFC 7507) No fallback possible (OK), no protocol below TLS 1.2 offered SWEET32 (CVE-2016-2183, CVE-2016-6329) not vulnerable (OK) FREAK (CVE-2015-0204) not vulnerable (OK) DROWN (CVE-2016-0800, CVE-2016-0703) not vulnerable on this host and port (OK) make sure you don't use this certificate elsewhere with SSLv2 enabled services, see https://search.censys.io/search?resource=hosts&virtual_hosts=INCLUDE&q=EE310C950635EF36ECB6C013BDFBD96C757BC074D88C0344B948429F26BBF94A LOGJAM (CVE-2015-4000), experimental not vulnerable (OK): no DH EXPORT ciphers, no DH key detected with <= TLS 1.2 BEAST (CVE-2011-3389) not vulnerable (OK), no SSL3 or TLS1 LUCKY13 (CVE-2013-0169), experimental potentially VULNERABLE, uses obsolete cipher block chaining ciphers with TLS, see server prefs. Winshock (CVE-2014-6321), experimental not vulnerable (OK) RC4 (CVE-2013-2566, CVE-2015-2808) no RC4 ciphers detected (OK) Done 2026-10-20 03:59:04 [ 175s] -->> 151.101.194.114:443 (assets-jpcust.jwpsrv.com) <<-- ----------------------------------------------------- Done testing now all IP addresses (on port 443): 151.101.66.114 151.101.130.114 151.101.2.114 151.101.194.114
About this Scan
This scan uses testssl.sh to check for:
- Protocols: SSLv2, SSLv3, TLS 1.0, TLS 1.1, TLS 1.2, TLS 1.3
- Vulnerabilities: Heartbleed, POODLE, FREAK, Logjam, DROWN, etc.
- Cipher Suites: Weak ciphers, perfect forward secrecy (PFS) support.