In this video, I talk about the POODLE attack- a bug that affected SSL v3.0 and below (all browsers but IE).

It allows malicious offensive traffic that looks like encrypted SSL traffic to be decrypted by a Man-in-the-Middle attacker so that they can get access to your data.

This is considered one of the worst security bugs found and affects lots of websites you visit, including Google and some banks!

If you want to know why you should reset your passwords.